WordPress 6.0.2 Patches Vulnerability That Could Impact Millions of Legacy Sites

WordPress 6.0.2 Patches Vulnerability That Could Impact Millions of Legacy Sites

The WordPress team this week announced the release of version 6.0.2 of the content management system (CMS), with patches for three security bugs, including a high-severity SQL injection vulnerability.

Identified in the WordPress Link functionality, previously known as ‘Bookmarks’, the issue only impacts older installations, as the capability is disabled by default on new installations.

However, the functionality might still be enabled on millions of legacy WordPress sites even if they are running newer versions of the CMS, the Wordfence team at WordPress security company Defiant says.

With a CVSS score of 8.0, the security flaw requires administrative privileges and is not easy to exploit in default configurations, but there might be plugins or themes that allow it to be triggered by users with lower privileges (such as editor-level and below), Wordfence says.

“Vulnerable versions of WordPress failed to successfully sanitize the limit argument of the link retrieval query in the get_bookmarks function, used to ensure that only a certain number of links were returned,” Wordfence explains.

In the default configuration, only the Links legacy widget calls the function in such a manner that the user can set the limit argument. However, due to safeguards in legacy widgets, the vulnerability is nontrivial to exploit.

Both of the two remaining vulnerabilities addressed in WordPress 6.0.2 are medium-severity cross-site scripting (XSS) bugs caused by the use of the ‘the_meta’ function and by plugin deactivation and deletion errors.

Successful exploitation of these vulnerabilities could lead to the execution of either scripts injected in post meta keys and values, or JavaScript code in the messages displayed when plugins are deactivated or deleted due to an error.

Website administrators are advised to update to WordPress 6.0.2 as soon as possible (the update is being automatically delivered to sites that support background updates). The patches have been backported to WordPress 3.7 and newer versions, the WordPress team notes.

Related: Malicious Plugins Found on 25,000 WordPress Websites: Study

Related: Unpatched WPBakery WordPress Plugin Vulnerability Increasingly Targeted in Attacks

Related: Exploited Vulnerability Patched in WordPress Plugin With Over 1 Million Installations

view counter

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:

Source link